Autencità del download di Ubuntu 16? Man-in-the-middle-attacks?


#1

Alberto2491

lugtsAncona1

Buongiorno. Sono nuovissimo, e mi sto impratichendo del forum e di tutti gli aspetti della comunità.
Non avevo mai pensato di cercare un’associazione come questa a Trieste… eppure è dal 2006 che uso Linux (stabilmente dal 2013).
Nell’ultima settimana ho avuto problemi inimmaginabili. Ho chiesto aiuto a un mio conoscente… Lui mi ha mandato il vostro link. Sono contento di aver trovato un’associazione come la vostra. Vorrei partecipare quanto prima alle vostre attività.

Cerco aiuto per risolvere dei problemi e per fugare dei dubbi. In tutti questi anni me la sono sempre cavata da solo, a colpi di Stack Exchange e googlate in genere. Stavolta non so cosa fare. Parto dall’inizio.

Quando scarico una nuova versione di Ubuntu, vedo che si consiglia di attestare l’autenticità del file, usando apposite chiavi. In passato ho tentato di imparare come usare quelle chiavi, ma non è facile.

Un fatto molto insolito: una volta nel 2015 ho aggiornato Ubuntu su un MacBook. Il risultato è stato uno schermo nero, come se sul disco interno ci fosse il nulla assoluto. (L’aggiornamento aveva cancellato la versione precedente di Ubuntu.)

La settimana scorsa sono riuscito a installare Ubuntu su un nuovo portatile, in dual boot con Windows 10. Riuscirci senza far fuori le altre partizioni è stato un grande successo per me (sono un paramedico, non un informatico). Ma ci sono riuscito solo con Ubuntu 17. Inizialmente volevo mettere la versione 16, in quanto LTS, ma l’installazione si è bloccata all’ultimo minuto. Una ricerca su Google rivelava che altri avevano avuto lo stesso problema, e sospettavano un bug. Ma devo sospettare qualcosa di peggio? un man-in-the-middle-attack?

L’installazione di Ubuntu 17 invece sembrava andata a buon fine (sempre senza far fuori partizioni). Ma subito sono cominciati problemi. Non riuscivo a scaricare nessuna app. Dopo il riavvio, sono riuscito a far partire anche gli aggiornamenti. Ma viene fuori un problema dopo l’altro. Quando sembra di aver trovato la soluzione, ne viene fuori un problema peggiore. nella fattiscpecie: non ottengo permessi da amministratore. Non riesco a fare nulla di nulla. Ubuntu non carica il disco meccanico in modalità rw, ma solo read-only. (Questo è un problema serio perché l’unità SSD ha solo 120 GB.) Non riesco a modificare fstab perché non ottengo il permesso. Perché? non ha senso. Non mi era mai successo niente di simile. Le ho provate tutte per far andare l’autorizzazione. Sono super user… eppure non c’è niente da fare.
Che Ubuntu ho scaricato? … Sarà quello autentico?


#2

Ciao e benvenuto.

Andiamo per punti:

  • Verificare l’autenticità della distro:
    1 - da dove hai scaricato la iso scarica anche il file sha256, poi esegui da terminale sha256sum sulla iso scaricata. es sha256sum Scaricati/ubuntu-17.04.iso .
    Verifica poi che i numeri corrispondano a quelli pesenti nel file scaricato (https://tutorials.ubuntu.com/tutorial/tutorial-how-to-verify-ubuntu#0)
    2 - Sul sistema installato, puoi usare rkhunter che ti verifica i binari di sistema, i files di config e l’eventuale presenza di rootkits. http://rkhunter.sourceforge.net/

  • Riguardo ai problemi di installazione delle app, dovresti essere un po più specifico, magari incolla l’errore che ti viene fuori.

  • Stessa cosa per il fatto che non hai i permessi di amministratore, incolla il comando che usi e l’output.

  • Il fatto che non riesci a montare il disco in scrittura potrebbe essere dovuto a molte cose, forse ti manca il pacchetto adatto, forse non ne sei il proprietario. Com’è formattato il disco meccanico?

Saluti


#3

Difficile capirlo. Può essere che hai sbagliato qualcosa nell’installazione. Comunque per risolvere potresti accedere a ubuntu e cambiare permessi con una distro live.

Saluti


#4

Grazie per la velocissima risposta!

  1. Grazie per le istruzioni sintetiche su come verificare l’autenticità. In questo momento non ho intenzione di reinstallare Ubuntu, anche perché potrei ricascare negli stessi stessi problemi. Non è dovuto a pura fortuna che sia riuscito a mantenere intatte le partizioni e fare il dual boot; ma non vorrei prendere sviste.
    Se però non riuscirò a risolvere i problemi mi sa che prima o poi dovrò resettare; allora verificherò l’autenticità.

  2. installazione delle app: appena avviato il sistema per la prima volta, come sempre ho provato a scaricare cose come vlc, Chromium, etc. Ma scrivendo “vlc”, non si metteva neanche a cercarla. Poi però dopo un primo riavvio il problema era risolto, e faceva anche gli aggiornamenti del sistema.

  3. Hai perfettamente ragione, avrei dovuto copiare e incollare il messaggio d’errore. È che sono nuovo, e aspettavo di avere risposta al primo quesito. (In realtà non sono mai stato deluso da esperienze di forum, mi hanno sempre risposto entro pochi giorni.) Entro oggi dovrei trovare il tempo di rifare il procedimento. Purtroppo è molto frustrante.

  4. Il disco meccanico è formattato in NTFS. Devo dire però che non avevo mai avuto problemi con Linux, semmai con Mac.
    Quando su un altro pc avevo solo sistemi Linux (Ubuntu, Mageia) in dual/multiple boot, avevo fatto in modo che Ubuntu montasse la partizione NTFS all’avvio, in modalità rw. Nessun problema con l’NTFS.
    Non vorrei dover formattare il disco in ext4, perché Windows non lo vedrebbe, quindi aver messo il dual boot perderebbe molto del suo senso.

Grazie. A risentirci a breve.


#5
  1. Elemento lista

Come si fa? devo accedere da un drive USB esterno?


#6

Se il disco è acceduto da Windows 10, probabile che il problema sia dovuto a dei flag lasciati da windows, prova a guardare qui: https://superuser.com/questions/880867/cannot-mount-ntfs-partitions-because-of-windows-10#880871

Nel caso prova comunque a montare il disco a mano e incolla qui l’output.

mount -t ntfs-3g /path/al/disco /path/cartella/dove/montare


#7

Alberto non accantonare l’idea di risolvere tutti questi problemi portando il tuo portatile a una delle nostre riunioni e parlando de-visu. È più veloce e da maggior conoscenza sul “contorno” del singolo problema.


#8

HO PROVATO a fare

gksudo gedit /etc/fstab
Failed to run gedit ‘/etc/fstab’ as user root.
Unable to copy the user’s Xauthorization file.

A questo punto, per risolvere il problema dell’Xauthorization, ubuntuforums.org suggerirebbe:

sudo chown chu:chu ~/.Xauthority

Al posto di chu:chu ho provato a mettere il mio username ubuntu-user@Dell-5770, e anche ubuntu-user@Dell-5770:ubuntu-user@Dell-5770
Qui forse mi sto perdendo in un bicchier d’acqua, perché la sua risposta è:
chown: invalid user: ‘ubuntu-user@Dell-5770’

IN ALTERNATIVA;
Ho anche provato installando NTDS Configuration Tool. Non lo lancia neanche: si apre una finestra che dice:
Failed to run ntfs-config as user root.
Unable to copy the user’s Xauthorization file.

Insomma sono superuser o no? di quali autorizzazioni ho bisogno?
Grazie a tutti per l’aiuto.


#9

Grazie, sarebbe la cosa migliore! Dove e quando vi incontrate? in via Ponziana? In più sarebbe una buona occasione per fare conoscenza coi membri dell’Associazione.


#10

Se una partizione NTFS non viene smontata in modo corretto o per causa
crash, Linux all’avvio successivo troverà il filesystem con il
cosiddetto “dirty bit” settato e quindi per non creare ulteriori danni
lo monterà in modalità read-only. In questo caso la partizione NTFS
necessita di un file system check e in un sistema dual boot un modo
semplice e sicuramente corretto per farlo è avviare Windows ed eseguire
uno “scandisk” sulla partizione problematica; se alla fine la partizione
risulterà pulita il “dirty bit” verrà resettato e Linux potrà rimontare
la partizione r/w come richiesto.
saluti,
Luciano


#11

Successo! adesso il disco viene montato rw! Grazie!


#12

Quindi il problema era causato da Windows 10.
Avevo in effetti già provato a spegnere bene Win10, ma senza togliere la spunta all’Avvio veloce non lo faceva comunque.


#13

Solitamente il Giovedì ci troviamo alla Casa del Popolo di Ponziana, in via Ponziana 14, dalle ore 20:30 :clock830:


#14

OK, prevedo dii esserci.


#15

Ma non dovrebbe aver formattato automaticamente la partizione in ext4 al momento dell’installazione?


#16

Non ho letto le mail precedenti :slight_smile: ho visto che il problema del disco era già stato risolto.


#17

Alberto, rileggendo il tuo primo messaggio non mi è chiaro se il tuo portatile nasce con SSD e HDD di fabbrica o se hai aggiunto uno dei due per installare Linux in dual boot; i due contesti sono leggermente diversi riguardo l’installazione, ma in linea di massima sì, se non fai una installazione manuale personalizzata, Ubuntu per default formatta la sua partizione di sistema con Ext4,
L.


#18

sarò alla casa del popolo intorno alle 20.45 di stasera